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Summary
This article provides a resolution for an issue where the Microsoft Teams dialer isn't visible in a custom app in Microsoft Dynamics 365 Sales.
Symptoms
A seller can't see the Teams dialer in a custom app.
Cause
The plug-in that installs the dialer to the custom app doesn't run when the seller doesn't have a Microsoft Teams license or a phone number assigned to their account.
Important
Before you continue, verify that the affected user has a Microsoft Teams license and a phone number assigned to their account. If either is missing, the plug-in that adds the dialer to the custom app doesn't run.
Solution
To fix this issue, re-add the custom app:
Go to the Microsoft Teams calls settings page. You can find this page in the Sales Hub app.
In the Advanced settings drop-down list, remove the custom app.
Select Update, and then refresh the page after it saves.
In the Advanced settings drop-down list, add the custom app back.
Select Update.
Open the custom app and verify that the dialer appears.
Note
If the dialer still doesn't appear after you re-add the custom app, try the Microsoft Teams dialer basic troubleshooting steps.